Jump to content

Pioneer install in Blobeye wagon


Recommended Posts

Hi all

After some advice on my stereo install. Had the scoob about 6 months now came with a aftermarket basic double din unit and I've just replaced that with a Pioneer avh unit. Installed it using the correct looms and grounded it to the chassis aswell as attached to the Subaru ground connection. The problem I have is the stereo works intermittently, when it does work it will freeze and do a reboot loop about 5 odd times before it works no problem untill I switch engine off and leave it a while and then it's back to square one. At the weekend I made a piggyback connection from a constant on the fuse box to see if that would help but it's the same. I've tried it out of the car on a power supply and it works perfectly all I can think of trying is running a constant from the battery direct to see if that does anything. If there's anyone out there with any help its appreciated. I've seen plenty of scoobs with different sound systems and they don't seem to have any issue

Thanks 

Link to comment

Did the old unit work OK?

Which Pioneer AVH  model??

Have you used an ISO to Subaru adaptor cable??

Harness adaptor.jpg

 

The radio has two supplies, 1 from the Battery (for memory ) and the other from the "Accessories" (power) output from the ignition system.

Have you connected the wires correctly in the supplied iso loom?

Basic  common blobeye audio wiring diagrams

Radio1.PNG

Radio2.PNG

 

 

 

 

Link to comment

Yh the old unit worked fine. It's the pioneer avh-x3700dab I've fitted. Yh I got a new scoob iso loom and pioneer loom both connected and getting correct voltage/output from the power & memory through the loom itself. But yet when the stereo was on a power supply it worked no issue so it can't be the unit itself. So I unplugged the constant from the loom and when to the fusebox to see if that would help but it doesnt

Link to comment

Just to confirm

At the Subaru loom pin 6 - Battery+ (Red/blue) connects to Yellow in the Subaru/ISO adaptor connects to Yellow in the radio loom.

At the Subaru loom pin 10 - Acc + (Yellow/green) connects to Red in the Subaru/ISO adaptor connects to Red in the radio loom.

Have you checked both fuses?  Battery+ in the fuse box under the bonnet (fuse #2)  and Acc+ in the fuse box drivers right knee (fuse #9)

If all above it could be a problem with the ignition switch, but if the old unit worked OK maybe not.

Assume the blue/white plugs are connected for the aerial amp?

also the parking brake switch connection is good?

 

Capture.PNG

 

Link to comment

Thanks for your help

Subaru loom to iso, all wires are correct. Both fuses are fine, check both power and accessory and both reading 12v +. The blue/white plug is connected fine & the parking brake wire (yellow/black) is earthed to chassis of cage 

IMG_20210309_181524.jpg

Link to comment

You say you've tried it on an external power supply and it's OK - what was the actual voltage??

Have you tried it in the car with a battery charger attached to the battery??

You may need to fully charge your car battery.

You may have a dodgy alternator - subaru use "intelligent" alternators that require a certain amount of load before they start recharging the battery

Link to comment

I tried it from 9v up to 13v to test the range. And I simulated turning car off and back on and the stereo worked perfectly. Yh I fully charged the car at weekend and tried it with the charger connected and was the same. I might have to check alternator but I'm totally confused with it all. The powers correct through the loom but yet plug the stereo in and fires up then reboots or freezes and does that loop for a while

Link to comment

Have you got it earthed property 

also try it without the aerial in.
some subarus have powered aerials already. The unit may also be trying to power aerial. 

also try without earth on handbrake cable.
 

I did have a Subaru din adapter that differed connection to speakers.  Test the colours match/go to right places

think it swapped one or two. 
 

tony
 

Link to comment

Latest update. I've got the original ground going through the loom and done a ground wire from the chassis to the cage where the original Subaru ground wire went. Tried it with nothing plugged in apart from the main loom and it's exactly the same no matter what you plug or unplug. Checked the loom and all wires correct. If I manage to get it working, drive somewhere and come back to my car shortly after it will work straight away no issues until say the next morning or later that day. But yet the alternators working fine and my battery's got plenty of charge in it. Just don't make sense to me

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...