Jump to content

De-limit Jap Import


Recommended Posts

Hi guys,

I have owned me Subaru for a few years now and am very happy with it. The car has been converted to MPH, but the car still seems to be limited to the standard 112MPH. I have taken my car to performance engineering and they said I already have a delimiter and converter in place. Has anyone got any ideas why the car is still limited? Is the converter/delimiter faulty? Any help will be much appreciated.

Many thanks

Link to comment
Hi guys,

I have owned me Subaru for a few years now and am very happy with it. The car has been converted to MPH, but the car still seems to be limited to the standard 112MPH. I have taken my car to performance engineering and they said I already have a delimiter and converter in place. Has anyone got any ideas why the car is still limited? Is the converter/delimiter faulty? Any help will be much appreciated.

Many thanks

Does your speedo still read in KPH?

Cheers Iain

Link to comment
Hi guys,

I have owned me Subaru for a few years now and am very happy with it. The car has been converted to MPH, but the car still seems to be limited to the standard 112MPH. I have taken my car to performance engineering and they said I already have a delimiter and converter in place. Has anyone got any ideas why the car is still limited? Is the converter/delimiter faulty? Any help will be much appreciated.

Many thanks

the top speed limit in this country is 70mph, so i hope you have not been

breaking the law, by going above this limit!!!!!!

unless your in a tunnel :driving::lol:

Link to comment
Just had a thought mate do the dials read in mph if so what does it read up to? What I am thinking is that it may just be the dials that have been replaced leaving the limiter still present.

Cheers Iain

The dials go up to 160MPH, When i have my Sat Nav installed the speed is about 8 or 9 mph out.

Link to comment
The dials go up to 160MPH, When i have my Sat Nav installed the speed is about 8 or 9 mph out.

Thats normal to be 7-8% out for a scoobie.

If your car is MY98 onward and the speedo has the original KMH face but is reading MPH then there must be something wrong with the wiring as the ECU is still taking it delimeter reading fro the gearbox feed before 'the box of tricks' and should be taking it after the speed has been adjusted.

If yours is a earlier car (without the digital mileometer), then the delimeter is just a mechanical geardriven attachment that sits in the cable and there is no wiring to go wrong.

Link to comment
Thats normal to be 7-8% out for a scoobie.

If your car is MY98 onward and the speedo has the original KMH face but is reading MPH then there must be something wrong with the wiring as the ECU is still taking it delimeter reading fro the gearbox feed before 'the box of tricks' and should be taking it after the speed has been adjusted.

If yours is a earlier car (without the digital mileometer), then the delimeter is just a mechanical geardriven attachment that sits in the cable and there is no wiring to go wrong.

Thats correct my car is My98 (Sept 98 - August 99) It does have the original KMPH dial face with the K blanked out. I will have a look at the wiring. It might just be a loose connection? I will have a look. Failing that i will but a new de-limiter/speed coverter and get that fitted.

Link to comment
Thats correct my car is My98 (Sept 98 - August 99) It does have the original KMPH dial face with the K blanked out. I will have a look at the wiring. It might just be a loose connection? I will have a look. Failing that i will but a new de-limiter/speed coverter and get that fitted.

I have some PDF's at home wth the wiring diagrams in, so Ill email them to you.

My guess is that it is a wiring fault and although the speedo says the '5' (MPG), the ECU is still getting a reading of '8' KPH and hence when it reaches 180 (KPH) it cuts the ignition when it should wait until 180mph. (although I have never tried that!)

Link to comment
I have some PDF's at home wth the wiring diagrams in, so Ill email them to you.

My guess is that it is a wiring fault and although the speedo says the '5' (MPG), the ECU is still getting a reading of '8' KPH and hence when it reaches 180 (KPH) it cuts the ignition when it should wait until 180mph. (although I have never tried that!)

Yeah if you can please, that would be a great help. Many thanks. paul.thompson@medway.gov.uk

Link to comment
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...